Document automation is experiencing degraded performance.

Incident Report for Athennian

Resolved

The issues with document generation have been resolved, and we are monitoring to ensure stability
Posted Jun 09, 2025 - 11:20 MDT

Investigating

We are currently experiencing degraded performance with document generation. Our team is actively investigating the issue to determine the full scope and implement a fix.
Posted Jun 09, 2025 - 10:45 MDT
This incident affected: Document Generation.